Page 1 of 1

Secure Log in Problems with Firefox

PostPosted: Sat Mar 18, 2017 1:07 pm
by Ulfisch
I hadn't logged in to the Lux website for the last 10 days because I always got a pop-up message that "Log in not secure" when trying to put in credentials using Firefox

Had chatted to a few people ingame and there was another chap who had the same problem for the last 10 days or so.

I also tried to put https:// in front of adress which led to a Firefox alert screen "Owner of website has not configured correctly" or something to this effect.

Yesterday someone suggested using another browser and that's what I'm doing just now, using Chrome. there doesn't seem to be any problem, however the URL shows simply http://www.luxarcana.org and not https://www.luxaracana.org

Could someone in the know tell me if this is a problem with my own settings, or perhaps a Firefox update possibly changed something or if the something with the security setting of our website has changed and needs to be updated?

Thanks for your help

Re: Secure Log in Problems with Firefox

PostPosted: Sat Mar 18, 2017 2:51 pm
by Belteyn
We do not use SSL for the main site so the prefix is http and not https i.e. http://www.luxarcana.org

As for why you get a message in Firefox, that's probably down to your settings in Firefox. I use Firefox and I don't get that message. There is nothing "insecure" about this website, but like 3/4 of the websites in the world there is not reason for us to use SSL currently. So any browser option to warn you about non-SSL sites is a bit pointless tbh.

Re: Secure Log in Problems with Firefox

PostPosted: Mon Mar 20, 2017 11:14 am
by Adreu
It comes with the new Firefox update, added security measures.